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Microsoft Project is fairly straightforward to use if configured properly, but very frustrating to use if not configured properly. Spending the extra time up front on the proper configuration will yield benefits later by making it easier to modify and maintain your project plan. 

There are many types of projects, and therefore, many types of project plans. But by adhering to certain core principles, you’ll have success using Microsoft Project. 

There are many ways to use Microsoft Project, and many features that won’t be mentioned in this document. The methodology outlined below works. Here are the basic steps for creating a project plan using Microsoft Project:
(1) Choosing a Microsoft Project template

· Depending on the type of project, you may want to start with a template provided by the Governance team or a plan from a similar project. This will increase the chances that you are including standard organizational deliverables in your plan. (This procedure assumes you will be starting without a template).

· Most projects will want to follow a phased approach when creating the plan structure. Phases include:

· Initiation

· Requirements

· Design

· Construction

· Test

· Implement

· Operate

(2) Planning Preparations
· It is advisable to create a Work Breakdown Structure (WBS) prior to entering tasks in the plan. A WBS contains the high-level tasks known at the beginning of the project, including the task predecessor relationships. Resources and task durations can be added if known.

· Here is an example of a partial WBS:


[image: image1]
(3) Verifying Toolbar settings

· Open the Microsoft Project tool

· Verify that the Standard and Formatting toolbars are activated:
· Right click on the toolbar area at the top of the screen

· Ensure Standard and Formatting are checked. If not, left click on those which are missing.

(4) Helpful hints

· Save frequently. Microsoft Project only supports a single Undo at a time.

· Use the backspace key when removing the contents of a cell. Microsoft Project will delete the entire row if you use the Delete key when trying to remove the contents of a cell.
(5) Populating Project Information
· Select the Project pull-down menu

· Select Project Information
· Select the project Start Date (defaults to today’s date)
· Leave the other default values alone
· Press the OK button.
(6) Configuring columns
· Select the View pull-down menu

· Select More Views…
· Select Task Sheet, then press the Apply button
· Using the steps in this section below, add/modify the default columns so that the following columns appear in the order shown (you can change this later if you wish):
· % Complete
· Task Name

· Duration
· Predecessors

· Start

· Finish

· Resource Names

· Text1 (will be changed to “Comments” later)
· Adding columns: 

· To add a column, right click on the column name header that you want the new column to appear to the left of
· Select Insert Column…
· Select the column name you wish to insert from the Field Name pull-down menu, then press the OK button.
· For example, to add the % Complete column, right click on the Task Name field header, select Insert Column, select the % Complete field from the Field Name pull-down menu, and then press the OK button.
· Ordering columns:

· To change the order that a column appears on the page, right click on the column name header that you wish to temporarily remove
· Select Hide Column…
· Reinsert the column at the desired location
· No data will be lost when columns are inserted or hidden
· Modifying column headings:
· Once the above columns are populated in the preferred order, the column heading names can be modified.
· Double left click on the column name header, modify the column alignment as desired, then press the OK button
· Press the Best Fit button to automatically set the column width

· When modifying the Text1 column heading name, change the Title field to “Comments”, then press the OK button
(7) Adding tasks
· Enter all known tasks in the Task Name column, based on the project phases, WBS, and other inputs already prepared. Do not populate/modify other columns until all tasks have been entered.
· Tasks should be broken down into measurable, manageable units (i.e., should not exceed one week in duration). This will enable you to better manage the project and report progress each week.
· Structure tasks in logical, chronological order
· Use the left and right arrows on the Formatting toolbar to set hierarchical task relationships
· Tip:  Tasks can be cut/copied/pasted by placing the cursor over the task numbers on the left side of the screen and highlighting the appropriate rows

(8) Setting predecessors

· Do not start this section until all known tasks have been entered within the desired hierarchical relationships.
· To create a plan that is easily maintainable, use predecessors to automatically calculate the task dates throughout the plan. Avoid overriding/setting dates.

· All tasks default to the project Start Date entered in the Project Information screen, as noted above, before they are modified. Predecessors allow task dates to be recalculated based on other task dates.
· Predecessors are populated in the Predecessor column for each task. To set a predecessor, simply enter the number of the task that you wish to precede it. Multiple predecessors can be added to a single task.
· Do not populate predecessors in Summary (bolded) tasks. Although it is allowed, it does not enable you to accurately configure task relationships/dates underneath the summary task.
· Add additional tasks/predecessors (or rework existing ones) if necessary to ensure a logical task/predecessor flow.

· Tip:  The linked task feature can be used to speed up the process for setting predecessors. To use this feature, highlight the detail tasks you wish to link together in a predecessor relationship, then press the Link Tasks button on the Standard toolbar. To unlink tasks, highlight the rows you wish to unlink, then press the Unlink Tasks button (next to the Link Tasks button). Just place your cursor over the buttons to determine which button is which.
(9) Entering resources

· Select the View pull-down menu

· Select Resource Sheet
· Enter the names of the project resources in the Resource Name field in the following format: Last Name <space> First Name Initial <period>. Example:  Smith J.
· When you are finished adding all the known resources, sort them in alphabetical order by
· Select the Project pull-down menu
· Select Sort
· Select By Name
· Return to the task sheet view
· Select the View pull-down menu
· Select More Views…
· Select Task Sheet
(10) Assigning Resources to Tasks

· Do not start this section until all tasks, predecessor relationships, and resources have been entered

· Place the cursor in the Resource Name field for the task that the resource(s) will be assigned to

· Select the Assign Resource button on the Standard toolbar

· Place the cursor on the resource to be assigned, then press the Assign button. Repeat for each resource to be assigned to the task. 

· If any errors occur during the data entry process, place the cursor on the resource to be removed, then press the Remove button

· Press the Close button when finished

· Repeat this process for each task. Do not assign resources to Summary (bolded) tasks.
· Tip:  The Fill Down feature can be used to speed up the process for adding resources. This feature copies data from a cell to one or more cells located directly below it. To use this feature, highlight both the source and destination cells, right-mouse on the highlighted selection, and then select Fill Down.
(11) Populating durations

· Do not start this section until all tasks, predecessor relationships, and resources have been assigned
· Enter the time it takes to complete a task in the Duration column for each task. Duration is the elapsed time it takes to complete a task, not the effort time. Example: It may take eight hours for an engineer to configure a UNIX server (effort), but the work is spread out over three days (duration).
· Add additional tasks/predecessors (or rework existing ones) if necessary to ensure a logical task/predecessor flow
· Adjust durations as needed to ensure the plan is reasonable
· If constrained by mandated milestone dates, align the durations to ensure the calculated summary dates match the milestone dates
(12) Populating the Percentage Completions
· Do not start this section until all tasks, predecessor relationships, resources, and durations have been entered

· Enter the percentage completed for each task as appropriate. Do not enter percentage completed in the Summary (bolded) tasks.
(13) Adjusting the Plan
· It is inevitable that changes will need to be made to plans. Realize that Microsoft Project may recalculate plan dates whenever changes are made. This creates a great deal of frustration for users who are not aware of this. Here are some things to consider when making plan adjustments:
· When adding resource(s) to a task that has already been populated with a Duration and/or a % Complete, realize that the task Duration and % Complete numbers fields will be recalculated and may change. The Duration and % Complete tasks may need to be adjusted after additional resources are added.
· If a task is marked 100%, the dates/durations associated with it will not be recalculated. When re-planning, it may be necessary to temporarily reset some/all % Complete values to zero to allow Microsoft Project recalculations to include these tasks.
(14) Overriding dates
· In some cases, dates must be fixed rather than calculated using predecessors. Do not type a date in the date field; this will diminish the maintainability of the plan. Here are the steps to override a calculated date:

· Double left-click on the task that will contain the date override

· Select the Advanced tab

· Select the appropriate date override in the Constraint Type pull-down menu. For an explanation of constraint types:

· Press the F1 key to access Microsoft Project Help
· Select the Answer Wizard tab

· Type in “Constraint Indicators”, then press the Search button

· Review the explanations in the About Indicators topic

· Select the Date in the Constraint Date pull-down date menu

· Press the OK button

(15) Comments

· The Comments column can be used for a variety of purposes including:
· Additional/explanatory information about the task
· Weekly Status Updates
(16) Formatting the Plan for presentation

· At some point, the plan will be reviewed.  It may be desirable to hide 100% complete summary tasks from view when presenting a plan so the reviewer can focus on certain sections of the plan. To do this…

· Click on the (-) sign in the Task Name column to the left of the summary task text. This will contract all tasks within the Summary task. To expand the group of tasks, press the (+) next to the summary task. The (-) and (+) buttons on the Formatting toolbar can also be used to contract/expand highlighted groups of tasks.
· To modify the hierarchy of tasks displayed, press the Show pull-down menu on the Formatting toolbar, then make the appropriate selection.

(17) Printing the plan

· Do not print the plan until it has been formatted for presentation and the Page Setup steps below have been completed

· Page Setup Paper steps

· Select the File pull-down menu

· Select Page Setup
· On the Page tab, in the Orientation section, select Landscape
· On the Page tab, in the Scaling section, select Fit to. Use the arrows to configure the report to be “1” pages wide and an appropriate number of pages tall.
· On the Page tab, in the Other section, click on the Paper Size pull-down menu and select “Letter” or “Legal” as appropriate.

· Page Setup Header steps
· On the Header tab, click on the Insert File Name button

· Highlight the &[File] text displayed, then press the Format Text Font button (which appears as a capital “A”)
· Adjust the font, considering that it will appear at the top of each page of the plan. Suggestion: Arial, Bold/Italics, 16, underlined.
· If necessary, rename the file so that it reads well at the top of the page. Use a date suffix in the file name used to aid in version control.
· Page Setup Footer steps

· On the Footer tab, highlight the default text displayed, then type in the word “Page” followed by a space
· Press the Insert Page Number button (which appears as a “#”)

· Type in the word “of” followed by a space and press the Insert Total Page Count button (which appears as “++”)

· Press the OK button once all the Page Setup Paper, Header, and Footer configurations have been completed.
· Preview the plan to ensure the formatting is correct, then print the plan

(18) Creating a Filter
· Filters are used to help reviewers focus on tasks that are past due or coming due in the near future

· Select the Project pull-down menu

· Select Filters
· Select More Filters
· Select New
· Enter the desired filter name in the Name field
· Select the Show in Menu checkbox
· Press the Insert Row button and populate the rows exactly as shown in the table below:
	And/Or
	Field Name
	Test
	Value(s)

	
	% Complete
	Does not equal
	100%

	And
	Finish
	Is less than or equal to
	“Enter Review Date”?

	And
	Summary
	Does not equal
	Yes


· When finished, press the OK button
(19) Accessing and using a filter

· Select the Project pull down menu

· Select the Filtered For option

· Select the More Filters option

· Select the filter created in the previous section
· Press the Highlight button

· In the Enter Review Date field, type in the date which is two weeks from now (MM/DD/YY format).

· This filter will allow the reviewer to focus on all past due tasks and all tasks due in the next two weeks
(20) Other notes
· Since Microsoft Project files are often large, they should be stored on shared drives as zipped files.

· Since many people do not have Microsoft Project software, it is recommended that project managers get Acrobat Adobe Writer software so they can easily convert Microsoft Project files into PDF format for stakeholder meetings
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